Hi, I was trying set up an old baby monitor from 4 years ago for my new bub. Its a Tomy srv400. Never had problems before but it won’t turn on. Any one else experience this problem?


Posted anonymously, 21st February 2016


Want more real mum questions sent to you?


Ask your question

  • If it’s been in storage for the last 4 years, it could be something simple like dust inside it. Can you unscrew it and give it a but of a blow out for the insides? Maybe it’s been damaged during storage



  • They’ve got a good helpline – try googling them.



  • With my monior of a difeerent brand i had to hold the main key down on both the base monitor and the one that makes the sound till they had the same number show up on the screen…. i also had to play with the other fuctions on it till the sound turned on.. turns out in had the ovement monitor on and the sound on turned off dont know i that will help you at all but ours had lasted seven yars of use between all our kids…



  • We just went to set up our old baby monitor and it won’t work… could be that they just don’t last.



  • They don’t seem to last from child to child – if changing the batteries doesn’t work, it is probably worth investing in a new one. If its still in warranty, contact the manufacturer/store purchased from.


Post an answer
Like Facebook page

LIKE MoM on Facebook

What is your answer to that question?
Would you like to include a photo?

No picture uploaded yet
Please wait to see your image preview here before hitting the submit button.

Your MoM account

Lost your password?

Enter your email and a password below to post your answer and join MoM:

↥ Back to top

Thanks For Your Star Rating!

Would you like to add a written rating or just submit?

Write A Rating Just Submit
Join